SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict
    Join Date
    Mar 2001
    Posts
    379
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Issue with Images

    Hello,

    On my new site AgentsWhotTweet - Find real estate agents on Twitter! I am having trouble with the little image next to the tweet in IE. They seem fine in Firefox and Chrome, but just noticed the issue in IE.

    What changes do I need to make to the CSS to prvent that image box from appearing above the thumbnails?

    I really appreciate the help!

    Thanks,

    Jon

  2. #2
    SitePoint Wizard Stomme poes's Avatar
    Join Date
    Aug 2007
    Location
    Netherlands
    Posts
    10,276
    Mentioned
    50 Post(s)
    Tagged
    2 Thread(s)
    Hi Jon,

    AgentsWhotTweet
    Is it supposed to be Agents Who Tweet? Not Agents Whot Tweet?

    I am having trouble with the little image next to the tweet in IE. They seem fine in Firefox and Chrome, but just noticed the issue in IE.
    Those other browsers are covering up for you; IE is just tellin ya how it is (for once).

    What changes do I need to make to the CSS to prvent that image box from appearing above the thumbnails?
    To the CSS? For now, none. This HTML:
    Code:
    <div class="image-box">
    <img class="photo">
    <a href="http://www.twitter.com/AgentsWhoTweet" target="_blank"><img class="userPicThumb" src="http://a0.twimg.com/profile_images/1291960126/twiticon_normal.jpg" alt="" /></a>
    </div>
    is invalid. The first image is displaying as not loaded in IE (because it's illegally got no src attribute!). Write them like so:
    Code:
    <div class="image-box">
      <a href="http://www.twitter.com/AgentsWhoTweet">
        <img src="http://a0.twimg.com/profile_images/1291960126/twiticon_normal.jpg" alt="" />
      </a>
    </div>
    Then the a and img don't need classes:
    .image-box a {
    anchors styles (you'll want to make it a block so either display: block + a width, or floating it... IE will want Haslayout on this)
    }

    .image-box a img {
    styles for the thumbnail
    }

  3. #3
    SitePoint Addict
    Join Date
    Mar 2001
    Posts
    379
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks! And thank you for catching the typo in the title! LOL I was wondering what was taking Google so long to index! LOL


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •