SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Mar 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Globalize I18n and Ruby upgrade

    Hello,

    I believe I posted this to the correct forum, please advise if I did not

    We're in the process of upgrading Rails from 1.2.6 to 3.0.4 (Ruby 1.8.7 and Gem 1.5.2). As part of this upgrade we need to also update from Globalize 1 to I18n, as our application incorporates over 25 languages.

    We have not found any documentation detailing the upgrade path from 1 to I18n and we are posting to find out if anyone could offer some guidance/methodology to help us execute the upgrade; as usual the more detailed the better.

    If this outside the scope of a message board, a pointer to a trusted consultant would be much appreciated.

    Thanks!
    Michael

  2. #2
    SitePoint Wizard
    Join Date
    Mar 2001
    Posts
    3,537
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ruby 1.8 and 1.9 are not compatible with respect to Unicode and UTF-8. Essentially, someone at your company has to learn the new Unicode rules and rewrite the code. There is enough blogging about the changes and deficiencies to Unicode in 1.9 to get a pretty good handle about what's going on.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •