SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: #1064!

  1. #1
    SitePoint Member
    Join Date
    Feb 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    #1064!

    I need some help with code.

    CREATE TABLE `iTracker` (
    `id` int(6) NOT NULL auto_increment,
    `serial` text NOT NULL default '',
    `name1` text NOT NULL default '',
    `name2` text NOT NULL default '',
    `ip` text NOT NULL default '',
    `time` text NOT NULL default '',
    PRIMARY KEY (`id`),
    UNIQUE KEY `id` (`id`)
    )TYPE=MyISAM AUTO_INCREMENT=1;

    That is my code, and I am getting this error:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM AUTO_INCREMENT=1' at line 10


    Please help!

    Thanks in advance,

    Charlie

  2. #2
    SitePoint Enthusiast
    Join Date
    Dec 2010
    Location
    Canada, Alberta
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the code works fine on my mysql, what version of mysql are you using?

  3. #3
    SQL Consultant gold trophysilver trophybronze trophy
    r937's Avatar
    Join Date
    Jul 2002
    Location
    Toronto, Canada
    Posts
    39,220
    Mentioned
    58 Post(s)
    Tagged
    3 Thread(s)
    change TYPE=MyISAM to ENGINE=MyISAM
    rudy.ca | @rudydotca
    Buy my SitePoint book: Simply SQL
    "giving out my real stuffs"

  4. #4
    SitePoint Member
    Join Date
    Feb 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up

    Quote Originally Posted by r937 View Post
    change TYPE=MyISAM to ENGINE=MyISAM
    Thank you very much, that seemed to do the trick.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •