SitePoint Sponsor

User Tag List

Page 4 of 4 FirstFirst 1234
Results 76 to 81 of 81
  1. #76
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Correct the path to the .js file by changing the src URL from

    Code:
    http://www.thecreativesheep.ca/fadeinsequence.js
    to

    Code:
    http://www.thecreativesheep.ca/construction/fadeinsequence.js
    In your CSS, give the ul containing the list items a suitable height to prevent it from collapsing when the list items are hidden.
    Code CSS:
    #services_content { height:4em }

    Then add the following to run when the page loads.
    Code JavaScript:
    $(document).ready(function() {
    	$("#services_content li").hide().fadeInSequence(2000);
    });

  2. #77
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't know if it's working, it may be loading too fast for me to tell. I replaced the previous script within the HTML page with the one you had posted, unless I was suppose to keep the other script as well ?

  3. #78
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Your page has not been updated.

    Yes, this script:
    Code JavaScript:
    $(function(){
    $("#Serv").click(function() {
        $("#Serv").children().hide().fadeInSequence();
        });

    Should be replaced with:
    Code JavaScript:
    $(document).ready(function() {
        $("#services_content li").hide().fadeInSequence(2000);
    });

  4. #79
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Script works exactly how I want it.
    Problem is each time the DIV loads the script should load, it only loads once upon the page loading.

  5. #80
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SiberianHuskey View Post
    Script works exactly how I want it.
    Problem is each time the DIV loads the script should load, it only loads once upon the page loading.
    That's what you asked for in post #70:

    I only want it to fade in when the page first loads, then stops.
    Time for a new thread.

  6. #81
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I wasn't specific, it's best to finish this problem off then start a new thread for a completely different issue.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •