SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    Jan 2011
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Horizontal scroll - what am I doing wrong?

    I'm trying to get horizontal scroll to work on my website. Basically view click on the arrow images and the images would scroll left and right. However I can't seem to get it to work correctly. What am I doing wrong? So very confused right now....

    Website in question: http://www.boblai.com/test.html

    Thanks!

  2. #2
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,198
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Your using a prototype script but you haven't included the prototype library into your source, do that and it will work correctly.

  3. #3
    SitePoint Member
    Join Date
    Jan 2011
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I added

    <script type="text/javascript" src="js/prototype.js"></script>

    in my code but still doesn't work?

  4. #4
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,198
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    It appears you need http://script.aculo.us/ as well as the .morph() method is not been found

  5. #5
    SitePoint Member
    Join Date
    Jan 2011
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ahhh forgot to include bunch scripts. Got it working now. Thank you so much!!!

  6. #6
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,198
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    No problem

  7. #7
    SitePoint Member
    Join Date
    Jan 2011
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Another related question...

    The horizontal scroll using the left and right arrows works now. In my css style sheet I have overflow set to auto so there's a horizontal scroll bar for scrolling. I did it this way just in case the viewer disables the browser javascript support.

    This is creating some problems... if you just use the horizontal scroll bar everything works fine; vice versa for just using the arrows. However you'll notice if you use the arrows the horizontal scroll bar begins changing its size. If you start using the horizontal scroll bar once you started using the arrows for scrolling everything messed up. Is there a way to fix this?

    Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •