SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2010
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with explorer to make 2 divs close to each other

    I was having trouble on Explorer when I was trying to add 2 Div's
    next to each other...
    one would be the up
    and the second div would be under him... with no SPACE between both divs...

    On Firefox it worked fine but on explorer I was seeing a line between...

    CSS Code:
    Code:
    .borders{width:900px; height: 530px;}
    .flashborder{width:900px; height: 302px;  }
    .inputborder{background: url(LowerPart.png); width:900px; height:228px;  }
    Main Page Code:
    Code:
    	<div class="borders">
    	<!-- The flash border next: -->
    		<div class="flashborder"><object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="900" height="302">
    		  <param name="movie" value="Images/HighPart.swf">
    		  <param name="quality" value="high">
    		  <param name="wmode" value="opaque">
    		  <param name="swfversion" value="6.0.65.0">
    		  <!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
    		  <param name="expressinstall" value="Scripts/expressInstall.swf">
    		  <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
    		  <!--[if !IE]>-->
    		  <object type="application/x-shockwave-flash" data="Images/HighPart.swf"  width="900" height="302">
    		    <!--<![endif]-->
    		    <param name="quality" value="high">
    		    <param name="wmode" value="opaque">
    		    <param name="swfversion" value="6.0.65.0">
    		    <param name="expressinstall" value="Scripts/expressInstall.swf">
    		    <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
    		    <div>
    		      <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
    		      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
    	        </div>
    		    <!--[if !IE]>-->
    	      </object>
    		  <!--<![endif]-->
          </object>
    	  </div>
    	  <!-- The Lower part border next: -->
    		<div class="inputborder"></div>
    		
    		</div>

    What can I do to fix the problem,?

    Thanks in advance, Dan.

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,795
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    Hi,

    Do you have a link as its hard to debug problems like these without seeing the working page?

    You could try setting the object elements to display:block or perhaps floating them to kill any whitespace bugs.

    Code:
    .flashborder object{float:left}
    Other than that I'd need to see the thing to debug further.
    Last edited by Paul O'B; Jan 6, 2011 at 11:52.

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2010
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you!
    That solved the problem :]


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •