SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Evangelist
    Join Date
    Jun 2010
    Location
    Israel
    Posts
    523
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    infos goes to DB as '#%#^!'

    hey all,

    i've recently rebuilt my website but i have problems uploading infos in hebrew to the DB, any hebrew letter gets uploaded as @^#^%, whereas in the old website it worked fine.

    however i did not make any change to the uploading proccess itself, and the only things that might cause the problem are that i added a doctype of strict and changed my content type from windows-1255 to utf-8, altho i've tried removing those 2 lines (just to check if thats what causing the problem) and the problem was still there, altho pulling infos from the database to the website in hebrew is not a problem, so what can cause this? any hints?

    note: english letters gets uploaded just fine.

    thanks in advance

  2. #2
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,067
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    What Collation is the table set to and are you setting the connection to the db to use utf-8
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •