SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2001
    0 Post(s)
    0 Thread(s)

    Problems converting mysql to mssql

    Hello everyone, i am currently having 2 problems, while converting my mysql database to mssql. I am using the DTS services provided with MSSQL 2000, and the error message i am getting is:
    Error at destination for row number 1368. Errors encountered so far at this task: 1.
    Insert error column 6 ('Retail', DBTYPE_NUMERIC), status 12: Invalid status for bound data.
    Unspecified error.

    the data in field 6 row 1368 is 1326.95 and the field is:
    and MSSQL is making it Numeric(5,2)

    I tried to just type in 1326.95 into a row in mssql (on that table) and it worked fine...any ideas?

  2. #2
    SitePoint Addict
    Join Date
    Jun 2001
    Newcastle, England
    0 Post(s)
    0 Thread(s)
    Hmm, I'm surprised that you can enter that data without getting an error.

    A NUMERIC(5,2) column means that the largest number which should be enterable is 999.99 - (5,2) basically "the number can have up to 5 digits of which two come after the decimal point".

    So you could enter 1.1324123123123 and it would be truncated to 1.13, but you shouldn't be able to enter 1000 because it's too large for the column.

    Perhaps MySQL handles numerics in a different way (I'm not really au fait with MySQL)? But certainly for MSSQL, 1326.95 is too large to fit into a NUMERIC(5,2) field. You'll either need to massage your data, or else alter the column size (to, say, 6,2).

    Hope that helps .
    Nick Wilson [ - email - ]


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts