Anyone have any idea why yum wont update PHP further?

EDIT: Stupid form submitted itself.

Apache/2.2.3 (CentOS 5.4)