SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Evangelist
    Join Date
    Jun 2010
    Location
    Israel
    Posts
    523
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    using a password for my db

    hey guys,
    im using a pass for my DB, when im opening it normally using the pass it works fine, but when im trying to open it through the web (i.e. log in page) it always tell me that the password for the db file is wrong... what can be the problem?
    thats an access DB file if that matters
    this is the error msg:
    Code:
    Microsoft JET Database Engine error '80040e4d' 
    
    Not a valid password.
    this is my connection string
    Code:
    conn.Open "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=path\db.mdb; Persist Security Info=False; Jet OLEDB:Database Password=" & pass
    thanks for the help

  2. #2
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ulthane View Post
    (i.e. log in page)
    Login page to what exactly ulthane?

  3. #3
    SitePoint Evangelist
    Join Date
    Jun 2010
    Location
    Israel
    Posts
    523
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    is that acutally matters? i just gave an example of a page where i use the database, after pressing the login button i get that error above pointing at the line where the connection string is...and i've checked it a few times and the password i put on the connection string matches the one the DB file uses, so i dont know where the problem is :/

  4. #4
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What I mean is that maybe the password online could be different from your local one

  5. #5
    SitePoint Evangelist
    Join Date
    Jun 2010
    Location
    Israel
    Posts
    523
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    hey, thanks for the reply donboe, but i got it solved already in this topic

    http://www.sitepoint.com/forums/showthread.php?t=717335


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •