SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Oddly quote sign behavior

    I remember having this same situation years ago, but I don't remember how I solved it at that time. I'm referring to the single ' and double " keys. I have to hit a space or any other key before one of the two, I would like to use, appears?

  2. #2
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    What? Are you are saying when you want to press ' you have to actually hit the Spacebar or something before it prints on screen? Obviously with " you typically would have to press-down SHIFT.

    I suspect it's to do with your "keyboard and language settings" where your quote key might be set to do another action like an accented character.

    Maybe: Start > Control Panel > Regional & Language Options.

    Have you have enabled an international keyboard layout or something strange?

  3. #3
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by xhtmlcoder View Post
    What? Are you are saying when you want to press ' you have to actually hit the Spacebar or something before it prints on screen? Obviously with " you typically would have to press-down SHIFT.
    Thats indeed the case I have my keyboard set to Unites States International (Since that is the layout of my keyboard). When I just looked in Start > Control Panel > Regional & Language Options, as you suggested, I saw an extra option int correction (whatever that is). I removed that one but the problem persist.

  4. #4
    SitePoint Wizard silver trophybronze trophy mizwizzy's Avatar
    Join Date
    Apr 2006
    Location
    Ireland
    Posts
    1,322
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    donboe have you just the plain US option set? If that still isn't working it's worth giving the UK option a try too! (you'd never know)

  5. #5
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Well, there'll most likely be a mismatch somewhere between the keyboard and language settings. If you have another machine spare you could compare them. Though it would explain why you get this weird effect.

    Obviously I have a UK Keyboard and it does differ to the US-Keyboard slightly http://en.wikipedia.org/wiki/Keyboar...United_Kingdom If you read the US-International section it says uses keys ', `, ", ^ and ~ as dead keys.

    So as my first setting I have:

    EN English (United Kingdom)
    rather than EN English (United States) US and my Key settings are also set as such.

  6. #6
    Non-Member
    Join Date
    Dec 2010
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It is clear that the problem is somewhere between keyboard and settings. And the best option is to use that keyboard on another machine and see if it works there, then apply the same settings on your machine too.

  7. #7
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mizwizzy View Post
    donboe have you just the plain US option set? If that still isn't working it's worth giving the UK option a try too! (you'd never know)
    I indeed tried that and than everything works fine

    Quote Originally Posted by xhtmlcoder View Post
    Well, there'll most likely be a mismatch somewhere between the keyboard and language settings. If you have another machine spare you could compare them. Though it would explain why you get this weird effect.

    Obviously I have a UK Keyboard and it does differ to the US-Keyboard slightly http://en.wikipedia.org/wiki/Keyboar...United_Kingdom If you read the US-International section it says uses keys ', `, ", ^ and ~ as dead keys.

    So as my first setting I have:

    EN English (United Kingdom)
    rather than EN English (United States) US and my Key settings are also set as such.
    There must be a mismatch indeed. Like I said above, when I change it to EN English (United Kingdom) everything is working fine. Thank you for the article by the way.

    Quote Originally Posted by UK Wholesale View Post
    It is clear that the problem is somewhere between keyboard and settings. And the best option is to use that keyboard on another machine and see if it works there, then apply the same settings on your machine too.
    That could be bit of a problem since I'm talking about a laptop

  8. #8
    SitePoint Wizard silver trophybronze trophy mizwizzy's Avatar
    Join Date
    Apr 2006
    Location
    Ireland
    Posts
    1,322
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    That's great news Donboe, glad everything is working for you now

  9. #9
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    No worries, and now you'll know how to diagnose the problem if it reoccurs again.

  10. #10
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm very glad indeed. Thank you for the input


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •