Hi!

I want to migrate the contents of my site to WordPress. The problem is that it seems that there is encoding issue with the script I was using. The contents are listed as properly-encoded text in the front-end. However, when I try to access/export the table directly from the database using phpMyAdmin I see garbage characters.

The table has the following structure, and it seems that it has an inconsistent encoding configurations (note that the whole table character set is cp1256_general_ci (Arabic Windows-1256), while the one of all text rows inside is latin1_swedish_ci):

Table --------- Records ---- Type ----- Collation -------------- Size
- aila_dsha ---- 5,888 ------ MyISAM -- cp1256_general_ci --- 3.6 MiB

Field ----------- Type ------------- Collation --------------- Null ---- Default ---- Extra Action
- dsha_id -------- int(3) --------------------------------------- No ------ None ------- AUTO_INCREMENT
- dsha_name ---- varchar(100) ---- latin1_swedish_ci ----- No
- dsha_post ------ text -------------- latin1_swedish_ci ----- No ----- None
- dsha_time ----- int(11) -------------------------------------- No ----- 0
- dsha_ip -------- varchar(15) ----- latin1_swedish_ci ------ No
- dsha_lastip ---- varchar(15) ----- latin1_swedish_ci ------ No
- dsha_lasttime - int(11) -------------------------------------- No ----- 0
- dsha_edits ----- int(2) --------------------------------------- No ----- 0

The exported data is just useless. The text doesn't get properly encoded with any Arabic encoding I try to set to the exported file. I am lost..

Any help is highly appreciated.