windows 7 64-bit: Testing Server localhost (MySQL, Apache, PHP)

The Error: Dreamweaver CS5 attempting to load files to localhost test server
---------------------------------------------------------------
Started: 11/19/2010 2:49 PM

index.php - error occurred - An error occurred - cannot put index.php. Access is denied.

File activity incomplete. 1 file(s) or folder(s) were not completed.

Files with errors: 1
index.php

Finished: 11/19/2010 2:49 PM
-----------------------------------------------------------------



Hi, I'm having trouble getting Dreamweaver CS5 to communicate with my localhost testing server... may be related to root password (not sure at all though)

Root password created doing the following in command line interface:
mysqladmin -u root -p password "newpassword"

...where newpassword is my password...

I've verified that my password works with the following in command line:
mysqladmin -u root -p status


Could this password be interfering with Dreamweaver CS5 trying to communicate with root on my localhost? This is my best guess at my problem.

Is there a way to remove the password from root entirely (w/o replacing it with another password)? ...my best guess at a solution

Do I need to worry about having a non-password-protected Apache server root on my home computer?

Thanks so much for any input... spent a day and a half searching 'the google' with no luck. Dreamweaver CS5 does not give the option to configure a password when the test server is set to the local machine.