SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2007
    Location
    Northampton, UK
    Posts
    70
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS Mega Menus not working in IE8

    Hi guys,

    Can someone please take a look at this page and suggest why the drop-down menus are not appearing correctly in IE8? They do show up, but seem to disappear behind the "breadcrumbs" div:

    http://www.4you2.org.uk/about

    I've tried fiddling with z-index values, but to no avail.

    I have used the "mega menus" method from .net magazine's website:

    http://www.netmag.co.uk/zine/home/embrace-mega-menus

    Thanks,

    Tim

  2. #2
    SitePoint Evangelist
    Join Date
    Apr 2009
    Location
    South Carolina
    Posts
    458
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just checked with the latest Firefox and IE8. They both look the same. The breadcrumbs stay behind the drop down menu.

    One thing to consider is that I am using IE8 (64 bit), and the 32 bit version may behave differently.
    Each day is a learning experience.

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2007
    Location
    Northampton, UK
    Posts
    70
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for checking for me.

    The issue was originally flagged up by a colleague in another office, who was having the problem in IE8 but when I checked, it looked exactly the same as in Firefox... as you've just found.

    However, today, I'm having the same display problems too.

    I'll check from home and see what it looks like.

    Can anyone else see it correctly (i.e. as it appears in Firefox), or do the drop-down menus get cut off in line with the top of the "breadcrumbs" div?

    Thanks again.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •