SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Oct 2010
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Ror on snow leopard - installation issues

    Hi
    I'm new to Ror. Just got this book simply rails by patrick lenz from the stands.

    Seeing that my macbook (running snow leopard) has everything already installed, this is what I did..

    lenovo-t400:~ Anush$ rails new
    create
    create app/controllers
    create app/helpers
    create app/models
    create app/views/layouts
    create config/environments
    create config/initializers
    create config/locales
    create db
    create doc
    create lib
    create lib/tasks
    create log
    create public/images
    create public/javascripts
    create public/stylesheets
    create script/performance
    create test/fixtures
    create test/functional
    create test/integration
    create test/performance
    create test/unit
    create vendor
    create vendor/plugins
    create tmp/sessions
    create tmp/sockets
    create tmp/cache
    create tmp/pids
    create Rakefile
    create README
    create app/controllers/application_controller.rb
    create app/helpers/application_helper.rb
    create config/database.yml
    create config/routes.rb
    create config/locales/en.yml
    create db/seeds.rb
    create config/initializers/backtrace_silencers.rb
    create config/initializers/inflections.rb
    create config/initializers/mime_types.rb
    create config/initializers/new_rails_defaults.rb
    create config/initializers/session_store.rb
    create config/environment.rb
    create config/boot.rb
    create config/environments/production.rb
    create config/environments/development.rb
    create config/environments/test.rb
    create script/about
    create script/console
    create script/dbconsole
    create script/destroy
    create script/generate
    create script/runner
    create script/server
    create script/plugin
    create script/performance/benchmarker
    create script/performance/profiler
    create test/test_helper.rb
    create test/performance/browsing_test.rb
    create public/404.html
    create public/422.html
    create public/500.html
    create public/index.html
    create public/favicon.ico
    create public/robots.txt
    create public/images/rails.png
    create public/javascripts/prototype.js
    create public/javascripts/effects.js
    create public/javascripts/dragdrop.js
    create public/javascripts/controls.js
    create public/javascripts/application.js
    create doc/README_FOR_APP
    create log/server.log
    create log/production.log
    create log/development.log
    create log/test.log
    lenovo-t400:~ Anush$ cd new

    lenovo-t400:new Anush$ ruby script/server
    => Booting Mongrel
    => Rails 2.3.5 application starting on http://0.0.0.0:3000
    => Call with -d to detach
    => Ctrl-C to shutdown server

    I dont see ruby starting or mongrel browser opening up, can the experts help me out.

    Thanks
    Anush


    lenovo-t400:new Anush$ rails -v
    Rails 2.3.5
    lenovo-t400:new Anush$ ruby -v
    ruby 1.8.7 (2009-06-12 patchlevel 174) [universal-darwin10.0]
    lenovo-t400:new Anush$ gem -v
    1.3.5
    lenovo-t400:new Anush$ sqlite3 --version
    3.6.12

  2. #2
    Team ********* Louis Simoneau's Avatar
    Join Date
    Sep 2009
    Location
    Melbourne, Australia
    Posts
    228
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I'm not sure I understand what the problem you're having is? That output all looks ok to me


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •