SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2009
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PrettyPhoto Titles Cut Off

    I am using the Atlantica theme, and I am having a problem with the PrettyPhoto slideshow on Mac Firefox - for some reason, the title gets cut off on the top of the screen. Doesnt seem to happen in Safari... Any ideas of how to fix this ?

    http://colingoldberg.com/artwork/wireframe-series

    I am attaching a screenshot.

    Thanks so much,
    Colin
    Attached Images Attached Images

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,329
    Mentioned
    463 Post(s)
    Tagged
    8 Thread(s)
    Seems to me they are only cut off if the viewport (browser window) is not high enough to show the image and heading. There is a negative margin on the title of 15px (added by JavaScript, I think) but I don't think that's really the issue.

  3. #3
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Seems to me they are only cut off if the viewport (browser window) is not high enough to show the image and heading.
    Try opening Firebug and then viewing the images - they actually get scaled down to fit the available area but the problem with the titles disappearing doesn't occur so it doesn't happen at all window sizes. So the problem's with calculating the window height which is a problem with the js, not the CSS.

    Try creating a reduced down version of the page stripping out everything that doesn't need to be there to see if the problem persists.

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,329
    Mentioned
    463 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by Tyssen View Post
    Try opening Firebug and then viewing the images - they actually get scaled down to fit the available area
    Hmm, not for me in Firefox Mac. The image stays the same size no matter what the window size. If the window isn't as tall as the image, it starts to go off screen.

  5. #5
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Hmm, not for me in Firefox Mac.
    I'm on a Mac too; FF 3.6.10.

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,329
    Mentioned
    463 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by Tyssen View Post
    I'm on a Mac too; FF 3.6.10.
    How weird. That's exactly what I'm using.

    EDIT: Ah, I see, the script looks at the screen size when it open the photo enlargement. Resizing the browser window after than doesn't affect the image size. So the problem may bell be just the negative 15px margin on the title.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •