SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Zealot bemmott's Avatar
    Join Date
    Mar 2007
    Location
    NY, USA
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Anyone here conversant in phpBB forum coding?

    Being that I am banned from the phpBB forum (long story - don't ask!) I am hoping someone here might be able to give me a clue what's going on with this issue.

    Up until a few months ago, I used simple code in my styles.css file to color the text of a few of my sub-forums. Worked fine for maybe 6 months, and then ... gone. I have absolutely no idea why this stopped working. I have not upgraded my version or made any other changes that could conceivably caused this to cease working, at least as far as I can see. I use a slightly modified "subsilver2" template for my forum.

    The modified coding to handle this is ...
    Code:
    a.subcolor17 {
           color: #009900;
           font-weight: bold;
         }
    
    a.subcolor18 {
           color: #FF6600;
           font-weight: bold;
         }
    
    a.subcolor19 {
           color: #660099;
           font-weight: bold;
         }
    
    a.subcolor27 {
           color: #FF6600;
           font-weight: bold;
         }
    
    a.subcolor31 {
           color: #006666;
           font-weight: bold;
         }
    
    a.subcolor33 {
           color: #0099FF;
           font-weight: bold;
         }
    ... which as I said worked fine until recently. Now it has reverted back to the default blue colors. I'm baffled and have nowhere else to seek an answer. Can anyone help me out with this? Much appreciated if you can!
    Bruce ...

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    Where are those styles meant to apply? It would be handy to know what element those styles are meant to apply to. Otherwise it's a needle in a haystack.

  3. #3
    SitePoint Zealot bemmott's Avatar
    Join Date
    Mar 2007
    Location
    NY, USA
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Where are those styles meant to apply? It would be handy to know what element those styles are meant to apply to. Otherwise it's a needle in a haystack.
    They reference the color of the individual sub-forums, Ralph. They also set the font weight to bold. Is that what you mean? Like I said, I would expect someone would need to have some experience with the phpBB forum templates and styles for this.
    Bruce ...

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    I just want to go to a specific element that is meant to have those styles applying and see if they are applying or not. If not, then we can look at what is applying and possibly why it is applying. But I don't have time to search through the site to try to find elements with those classes on them.

    "Sub-forums" doesn't really mean anything to me.

  5. #5
    SitePoint Zealot bemmott's Avatar
    Join Date
    Mar 2007
    Location
    NY, USA
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    I just want to go to a specific element that is meant to have those styles applying and see if they are applying or not. If not, then we can look at what is applying and possibly why it is applying. But I don't have time to search through the site to try to find elements with those classes on them.

    "Sub-forums" doesn't really mean anything to me.
    Um... I'm not sure I understand what you're saying, Ralph, by "going to a specific element" to see if they're applying.
    Bruce ...

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    Those CSS rules you posted above are for styling links. All I'm asking is which links you want them to apply to. I didn't find any links in your site with classes like .subcolor17 on them.

  7. #7
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,777
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    I can't see any links on the site with those classes either. I looked through the html of half a dozen pages and there is no link with any of those classes added to it so nothing will get styled.

    What Ralph is asking is for you to show us the specific part of the page that has a link like this:

    Code:
    <a class="subcolor18" href="etc...........
    If you don't have any links like that then there won't be any styling applied to them.

  8. #8
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    Yes, thanks for clarifying Paul. I was thinking that if what we are asking still doesn't make sense, another way of putting it is: indicate a page where the problem is occurring, and tell us which part of the page doesn't look the way you want it to.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •