SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist Jhorra's Avatar
    Join Date
    Sep 2004
    Location
    Phoenix, Az
    Posts
    551
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Trying to get custom font working

    Edit: It appears to work in everything but IE, is there a hack for getting it to work in IE?

    I have the following lines in my CSS, and I've removed all other font styles:

    @font-face
    {
    font-family: poor_richard;
    src: url(url removed) format('opentype');
    }
    html, body
    {
    font-familyoor_richard;
    }

    I've verified that all my links are point to the correct files, is there something I'm doing wrong?

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,276
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Use the font squirrel generator to generate the needed fonts in the right format.

    Then read the reasons why here:

    http://paulirish.com/2009/bulletproo...tation-syntax/

  3. #3
    SitePoint Evangelist Jhorra's Avatar
    Join Date
    Sep 2004
    Location
    Phoenix, Az
    Posts
    551
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, after I posted this I found out about eot format, and got it all converted. Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •