SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict beebs93's Avatar
    Join Date
    Jul 2010
    Location
    Vancouver, Canada
    Posts
    207
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE7 + IE 5.5 haslayout bug?

    http://nupper.heliohost.org/version4/

    This only affects IE 5.5 and 7 (IE 6 and 8 are not affected).

    I can't seem to nail down why only 1 of the 3 divs with background PNGs are not showing.

    I'm using the TwinHelix png fix and the IE NetRenderer to allow three divs within the main container div to display different background PNG.

    The weird thing is 1 of the 3 ("entry_bg_bottom" div) does show up (even in IE 5.5 and IE 7).

    If not a haslayout problem, could the sticky footer IE-specific CSS be the culprit instead?
    Code:
    <!--[if (lte IE 6)|(gte IE 8)]>
    <style type="text/css">
    #container {height:100%;display:table;}
    </style>
    <![endif]-->

    Many thanks in advance

  2. #2
    SitePoint Addict beebs93's Avatar
    Join Date
    Jul 2010
    Location
    Vancouver, Canada
    Posts
    207
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    *sigh* Nevermind. I pulled my head out from my butt and read the haslayout reference material in a non-rushed state. Added zoom:1 to fix both IE 5.5 and 7.

    I need the equivalent of an oinking pig one puts in their fridge to lose weight whenever I try to post something.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •