SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    my embedded google map isnt centered... help?

    I used google maps to get the embed code for a google map which i am displaying on a sit I am building.

    the problem is that when you view it embedded on my page, the location on the map is waaaay off to the upper left corner and barely visible in the google maps iframe. how can I get the google map to load centered on the address?

    TO see what I mean go to http://www.thetirewarehouseinc.com/beta and click the "show map" button for the Troy Location (the first block on the left) to reveal the map.

    any idea how to get the google map to center??

  2. #2
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    anybody else have this problem with embedded google maps?

  3. #3
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    nobody can help with this? google searches keep mentioning map.checkresize but i don't know what that is.

  4. #4
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok i see that the map.resize refers to the google maps API. I am not using the API, just the standard embed code.

  5. #5
    SitePoint Wizard bronze trophy bluedreamer's Avatar
    Join Date
    Jul 2005
    Location
    Middle England
    Posts
    3,402
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    The marker is dead centre for me

  6. #6
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by bluedreamer View Post
    The marker is dead centre for me
    sorry take a look at this page:
    http://www.thetirewarehouseinc.com/beta/locations.html

    and click the "Map/Directions" link for one of the locations.

  7. #7
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    any ideas? i have banging my head on the wall with this one... seems like its a common problem but no real fix.

  8. #8
    SitePoint Zealot
    Join Date
    Jul 2006
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok well i wound up fixing the issue on the home page by using the google MAPS API instead of the simpler embed code. it was a lot more code but it did the trick.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •