SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Jan 2009
    Posts
    383
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Absolute positioned div disappears in IE6

    Hi all

    I'm having another problem with my current site, the problem only appears in IE6 so I don't know how bothered I should be about it - I still would like to fix it.

    http://www.ttmt.org.uk/css/

    This demo has a red box (Div) in the bottom left. The div is in the footer which is a sticky footer, the div is then positioned absolutely above the footer. This works fine in all browsers and when the browser is resized the red box moves up and down above the footer as expected.

    The problem is IE6 where the red box has disappeared.

    Is it possible get this working in IE6 ?

    How important is IE6 ?

  2. #2
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    try putting it at the very end of the footer html, giving it a left value, and a z-index value.

  3. #3
    SitePoint Addict
    Join Date
    Jan 2009
    Posts
    383
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the suggestion Eric. I tried it but still not working

    http://www.ttmt.org.uk/css/

  4. #4
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    dont know if this is the absolute culprit, but the width on the #footer #footer_Nav makes the orange box disappear. If you place the box inside the footer nav div it reappears or if you give the footer nav ul the width instead it reappears.

    #footer #footer_Nav ul{
    width:683px;
    }

  5. #5
    SitePoint Addict
    Join Date
    Jan 2009
    Posts
    383
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't know if it was a hasLayOut issue but I fixed the problem with clear:both on the div

    www.ttmt.org.uk/css


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •