SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    Visible Ninja bronze trophy
    JeffWalden's Avatar
    Join Date
    Sep 2002
    Location
    Los Angeles
    Posts
    1,709
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Post Cannot connect with phpMyAdmin

    I am probably overlooking something simple.

    I just recently setup a MySQL server on my local box for development. I have never setup my own server before, I have always used a professional host like rockethost.com. Anyway, I am trying to connect using localhost, user=root, and my pass I setup for the user root.

    I know I have the pass correct as that is what WinMySQLadmin uses to connect and it works.

    When I try to connect with phpMyAdmin, I get this message: Access denied for user: 'root@127.0.0.1' (Using password: YES)

    What am I doing wrong? Anybody have any ideas? I have setup phpMyAdmin before, but on another host and they gave me the user and pass to use. EVERYTHING WORKED THAT TIME!

    My head is spinning. Any help is appreciated no matter how trival it seems. I just am probably overlooking something simple.

    Ohh ya, this is a windows box.
    TAKE A WALK OUTSIDE YOUR MIND.

  2. #2
    Prolific Blogger silver trophy Technosailor's Avatar
    Join Date
    Jun 2001
    Location
    Before These Crowded Streets
    Posts
    9,446
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you configured your config.inc.php?
    Aaron Brazell
    Technosailor



  3. #3
    Visible Ninja bronze trophy
    JeffWalden's Avatar
    Join Date
    Sep 2002
    Location
    Los Angeles
    Posts
    1,709
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Yes, I have configured it with user=root, host=localhost, and my password.

    However, would it not authenticate me trying to log on as root? Do I need to use a real user to log on?

    Just an idea.
    TAKE A WALK OUTSIDE YOUR MIND.

  4. #4
    We like music. weirdbeardmt's Avatar
    Join Date
    May 2001
    Location
    Channel Islands Girth: Footlong
    Posts
    5,882
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't think it's sending your password properly (hence the password=YES message). Double check your phpmyadmin config files.
    I swear to drunk I'm not God.
    Matt's debating is not a crime
    Hint: Don't buy a stupid dwarf Clicky

  5. #5
    Visible Ninja bronze trophy
    JeffWalden's Avatar
    Join Date
    Sep 2002
    Location
    Los Angeles
    Posts
    1,709
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Still having problems. I re-configured the password, but am now getting CGI errors. I installed Active State Perl for IIS and set that up... still doesn't seem to work.

    Any idea?
    TAKE A WALK OUTSIDE YOUR MIND.

  6. #6
    Visible Ninja bronze trophy
    JeffWalden's Avatar
    Join Date
    Sep 2002
    Location
    Los Angeles
    Posts
    1,709
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    I found this post which is EXACTLY my problem...

    Hello,

    I'm writing in regards to this error----->
    cgi error:
    The specified CGI application misbehaved by not
    returning a complete set of HTTP headers. The headers it
    did return are:

    I've been to every message forum around the world and back and got
    nothing. What it did get me looking at lots was the php.ini file. I
    run a Win 2000 Server with the latest greast PHP 4.3.1 mySQL and IIS.
    When it hit me like a bull in a china shop, I've got this all up and
    running on my XP pro system to test my code on, let's look at that
    php.ini file, so I did. And I saw it.....

    XP setting: doc_root =
    IIS setting: doc_root = C:\Inetpub\wwwroot

    OK so I set my IIS php.ini doc_root to the XP setting
    doc_root =

    ...and WaBLAM! It worked!
    I added C:\Inetpub\wwwroot as the doc_root in my php.ini file (that is correct path) but it is still not working? What else am I missing?
    TAKE A WALK OUTSIDE YOUR MIND.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •