SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2008
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Puzzling issue with cross-browser compatibility

    I've got a design that I'm working on and all my layouts are working fine in Chrome, FF, and Safari. IE 8 is behaving, but when switching on compatibility mode it breaks and it does not render correctly in Opera 10 either. I use a CSS reset to standardize everything (I know some folks here hate that) but it's not correcting the problems in those two browsers.

    It seems like a positioning and margin problem. Here is the site if you wouldn't mind taking a look and offering a little feedback.

    http://s98021.gridserver.com/

    I'm still in the development stage for this site, so it may be a bit messy, but I'd appreciate any input or help.

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,380
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Try clearing the header-wrapper.

    Code:
    #header-wrapper{clear:both}

  3. #3
    SitePoint Enthusiast
    Join Date
    Jan 2008
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Paul O'B View Post
    Hi,

    Try clearing the header-wrapper.

    Code:
    #header-wrapper{clear:both}
    Paul - thank you. I appreciate your response. Worked perfectly! Sometimes it pays to have another set of eyes on your work!

    Thanks again.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •