SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict dgroves's Avatar
    Join Date
    Jan 2007
    Location
    Bath, UK
    Posts
    364
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    WordPress white screen

    Hi,

    I have done a fresh install of WordPress on a site, but I am being presented with a white screen, not the usual install screen. I have checked and I have the correct version of PHP and MySQL on the server (php info).

    The WordPress installation is here: http://wsbeorchids.org.uk/wordpress.

    Has anyone got any suggestions on what I can do to fix this?

    Thanks in advance,
    Dan.

  2. #2
    dooby dooby doo silver trophybronze trophy
    spikeZ's Avatar
    Join Date
    Aug 2004
    Location
    Manchester UK
    Posts
    13,788
    Mentioned
    151 Post(s)
    Tagged
    3 Thread(s)
    Hi Dan, this suggests that there is an error in the php install which is killing the process. On your phpinfo it shows that the display_errors setting is off which is why you get nothing but the white screen.

    Either edit the php.ini file (preferable) or add the following php code to top of the index page:
    PHP Code:
    ini_set("display_errors"1); 
    ERROR_REPORTING(E_ALL); 
    Mike Swiffin - Community Team Advisor
    Only a woman can read between the lines of a one word answer.....

  3. #3
    SitePoint Addict dgroves's Avatar
    Join Date
    Jan 2007
    Location
    Bath, UK
    Posts
    364
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi spikeZ,

    Thanks for you help!

    I don't have access to the php.ini so I went with the later of the two options. Upon doing this and refreshing I got the following error:

    Code:
    Fatal error: Call to undefined function: is_wp_error() in /var/www/vhosts/wsbeorchids.org.uk/httpdocs/wordpress/wp-includes/load.php on line 339
    I tried re-uploading load.php incase there was a problem caused by a faulty upload, but had no luck here.

    I should probably say now that I am not great at de-bugging with PHP. Below is the function that includes line 339.

    PHP Code:
    /**
     * Sets the database table prefix and the format specifiers for database table columns.
     *
     * Columns not listed here default to %s.
     *
     * @see wpdb::$field_types Since 2.8.0
     * @see wpdb::prepare()
     * @see wpdb::insert()
     * @see wpdb::update()
     * @see wpdb::set_prefix()
     *
     * @access private
     * @since 3.0.0
     */
    function wp_set_wpdb_vars() {
        global 
    $wpdb$table_prefix;
        if ( !empty( 
    $wpdb->error ) )
            
    dead_db();

        
    $wpdb->field_types = array( 'post_author' => '%d''post_parent' => '%d''menu_order' => '%d''term_id' => '%d''term_group' => '%d''term_taxonomy_id' => '%d',
            
    'parent' => '%d''count' => '%d','object_id' => '%d''term_order' => '%d''ID' => '%d''commment_ID' => '%d''comment_post_ID' => '%d''comment_parent' => '%d',
            
    'user_id' => '%d''link_id' => '%d''link_owner' => '%d''link_rating' => '%d''option_id' => '%d''blog_id' => '%d''meta_id' => '%d''post_id' => '%d',
            
    'user_status' => '%d''umeta_id' => '%d''comment_karma' => '%d''comment_count' => '%d',
            
    // multisite:
            
    'active' => '%d''cat_id' => '%d''deleted' => '%d''lang_id' => '%d''mature' => '%d''public' => '%d''site_id' => '%d''spam' => '%d',
        );

        
    $prefix $wpdb->set_prefix$table_prefix );

        if ( 
    is_wp_error$prefix ) ) // Line 339
            
    wp_die/*WP_I18N_BAD_PREFIX*/'<strong>ERROR</strong>: <code>$table_prefix</code> in <code>wp-config.php</code> can only contain numbers, letters, and underscores.'/*/WP_I18N_BAD_PREFIX*/ );


    This has left me a little confused as it appears to talk about the table prefix, which I haven't specified yet as I haven't got a wp-config file yet.

    Any suggestions?

    Thanks,
    Dan.

  4. #4
    dooby dooby doo silver trophybronze trophy
    spikeZ's Avatar
    Join Date
    Aug 2004
    Location
    Manchester UK
    Posts
    13,788
    Mentioned
    151 Post(s)
    Tagged
    3 Thread(s)
    unfortunately my WP knowledge is diddly squat but having had a quick search round: http://core.trac.wordpress.org/ticket/4308

    See if that helps you!
    Mike Swiffin - Community Team Advisor
    Only a woman can read between the lines of a one word answer.....

  5. #5
    The knight who said ni! RockyShark's Avatar
    Join Date
    Apr 2003
    Location
    Rockhampton, Australia
    Posts
    701
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    We had that trouble, but only with 3 (WP 2.9.2 was okay) and only on one specific host.

    If you're not up to fixing the bug yourself, roll back to 2.9.2 or try a different host.

    (Sorry, I can't remember what the actual config issue with the host was)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •