i just inserted the three pictures you see into this post: http://bandit4x4.com/wordpress/4x4-t...-arm-bushings/

when inserting them, i specified to align them to the right. but clearly its not doing that, how do i fix?

please advise. thanks in advance.

here's the code, post insertion:
Code:
[caption id="attachment_58" align="alignright" width="150" caption="Idler Arm Bushings - Top View"]<a href="http://bandit4x4.com/wordpress/4x4-truck-parts/steering-parts/oem-stock-idler-arm-bushings/attachment/idler-bushings-top/" rel="attachment wp-att-58"><img src="http://bandit4x4.com/wordpress/wp-content/uploads/idler-bushings-top-150x150.jpg" alt="Idler Arm Bushings - Top View" title="Idler Arm Bushings - Top View" width="150" height="150" class="size-thumbnail wp-image-58" /></a>[/caption]

[caption id="attachment_56" align="alignright" width="150" caption="Idler Arm Bushing - Inside View"]<a href="http://bandit4x4.com/wordpress/4x4-truck-parts/steering-parts/oem-stock-idler-arm-bushings/attachment/idler-bushings-inside/" rel="attachment wp-att-56"><img src="http://bandit4x4.com/wordpress/wp-content/uploads/idler-bushings-inside-150x150.jpg" alt="Idler Arm Bushing - Inside View" title="Idler Arm Bushing - Inside View" width="150" height="150" class="size-thumbnail wp-image-56" /></a>[/caption]

[caption id="attachment_57" align="alignright" width="150" caption="Idler Arm Bushing - Installed"]<a href="http://bandit4x4.com/wordpress/4x4-truck-parts/steering-parts/oem-stock-idler-arm-bushings/attachment/idler-bushings-installed/" rel="attachment wp-att-57"><img src="http://bandit4x4.com/wordpress/wp-content/uploads/idler-bushings-installed-150x150.jpg" alt="Idler Arm Bushing - Installed" title="Idler Arm Bushing - Installed" width="150" height="150" class="size-thumbnail wp-image-57" /></a>[/caption]

<strong>Product:</strong>
Idler Arm Bushings (Original Equipment Manufacture)