SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Script stopped working when I move from Windows to Linix

    I've been using a javascript routine to create slide shows for many websites including my own. Unfortunately, when I moved my site to a Linix hosted platform from a windows platform my slideshow stopped working. It still works on my XP system under IIS, but not when I upload it to my new server platform.

    Any ideas about what could cause such behavior would be greatly apprecited.

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,688
    Mentioned
    100 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by Art Hart View Post
    when I moved my site to a Linix hosted platform from a windows platform my slideshow stopped working
    We could help if we were to have a look at a test page that demonstrates the problem that you're having.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Post

    OK, here is a link to my website: websitesbyideal.com
    The home page is supposed to have a slide show running on the simulated monitor screen. I've attached a zip file containing the pictures and the scripts.

    Thanks for your interest.
    Attached Files Attached Files

  4. #4
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,688
    Mentioned
    100 Post(s)
    Tagged
    4 Thread(s)
    Currently the web site has a redirect loop, so it's not possible to view anything there at all.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  5. #5
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy

    Pardon me. I was experimenting and goofed.

  6. #6
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,688
    Mentioned
    100 Post(s)
    Tagged
    4 Thread(s)
    Okay, I now get a scripting error that fadeshow is not defined.

    I presume that this is related to a scripting file not being found.
    slides/slides.js
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  7. #7
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up

    I took the capital "S" off the slides folder and the slides.js file can now be found!
    Now that I've moved to a Linix platform, I'm going to have to go through ALL my folders and remove any capitals.

    Thanks again.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •