SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    May 2010
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question IE ignores table column width

    Hi!

    I'm running into some problems making IE behave.

    See http://www.clichespotting.com/#degreeshows

    It's the last column in the red table. It's meant to be the the same width as the last column in the blue table. It works in every browser except IE.

    I'm stuck. Can anyone tell me what's going on there?

    Thanks for your help!

  2. #2
    SitePoint Enthusiast David.A's Avatar
    Join Date
    May 2010
    Location
    Milky Way Galaxy
    Posts
    66
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rather then telling you what is wrong, I'll just give you a tip so you can learn to debug this stuff yourself.

    Considering that both tables are similiar, and one works, and one doesn't, What is different from the latter then the first? Finding that out and fixing it should resolve it for you.

  3. #3
    SitePoint Member
    Join Date
    May 2010
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help!

    This is my problem. I've been analysing it closely, but I can't see anything different. The red table has different content in the column in question, but I can't see how this would have an effect.

    The weird thing is that it works perfectly in other browsers and only IE doesn't work. Can you point me in the right direction?

    I appreciate your help!

  4. #4
    SitePoint Enthusiast David.A's Avatar
    Join Date
    May 2010
    Location
    Milky Way Galaxy
    Posts
    66
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I managed to get it down some by removing some margins and paddings, check that those are all the same. Also make sure that all your HTML is all the same.

    If that doesn't work, try rewritting your tables.

  5. #5
    SitePoint Member
    Join Date
    May 2010
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thank you! Can you say which margins and paddings you removed to fix it?

  6. #6
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,288
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    I believe IE needs the table-layout fixed algorithm for ellipses to work.

    e.g.

    Code:
     #coming{table-layout:fixed;}

  7. #7
    SitePoint Member
    Join Date
    May 2010
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up

    Quote Originally Posted by Paul O'B View Post
    I believe IE needs the table-layout fixed algorithm for ellipses to work.
    Excellent, Paul! This solves the problem. Lifesaver!

    I had no idea this even existed Lesson learnt.

    Thanks a lot, you are a star!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •