Hi

I'm trying to install rubygems, and the rails.
I have installed ruby already.
How do you do this? I can't find any help installing these?
I have downloaded the package and the instruction is:

(extract, then run "ruby setup.rb")

This file isn't executable, I tried in CMD with ruby, or should I use windows Run command?

Why is that always so that installing is the most difficult part, I have had more experiences. For example Java, there is no indication what do I have to download and they change the names, so the installing guides in the books won't match, then MySQL etc.