SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2009
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Post Ruby-debug gem install (Chapter 11)

    Simply Rails 2 2nd edition chapter 11

    Installing ruby-debug

    I would appreciate help on how to install this gem.

    Here's the output I got (rails -v=Rails 2.3.5, Windows XP, ruby console)
    Code:
    C:\InstantRails\rails_apps\shovell-debug-02>gem install ruby-debug
    Building native extensions.  This could take a while...
    ERROR:  Error installing ruby-debug:
            ERROR: Failed to build gem native extension.
    
    C:/InstantRails/ruby/bin/ruby.exe extconf.rb
    creating Makefile
    
    nmake
    'nmake' is not recognized as an internal or external command,
    operable program or batch file.
    
    
    Gem files will remain installed in C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/r
    uby-debug-base-0.10.3 for inspection.
    Results logged to C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/ruby-debug-base-0.
    10.3/ext/gem_make.out

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,185
    Mentioned
    191 Post(s)
    Tagged
    2 Thread(s)
    AFAIK "nmake" is a *nix thing. Could it be the gem installed OK even with those error messages?

  3. #3
    SitePoint Enthusiast
    Join Date
    Dec 2009
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Post

    Well in fact it did not. Othervise I wouldn't have started a thread about it.
    Here's the command to run server with debug
    Code:
    C:\InstantRails\rails_apps>cd coal
    
    C:\InstantRails\rails_apps\coal>ruby script/server --debugger
    => Booting Mongrel
    => Rails 2.3.5 application starting on http://0.0.0.0:3000
    You need to install ruby-debug to run the server in debugging mode. With gems, u
    se 'gem install ruby-debug'
    
    C:\InstantRails\rails_apps\coal>
    You are welcome to suggest something entirely different. Maybe I should re-install InstantRails or I don't know. I couldn't get "searchlogic" gem to work. I followed railscast about it but when I tried to edit config/environtment.rb then I couldn't start the server. Of course reverting changes fixes that.

  4. #4
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,185
    Mentioned
    191 Post(s)
    Tagged
    2 Thread(s)
    I think your problem might be InstantRails. I myself and quite a few others here in the forum seem to have had problems with it.

    I gave up on InstantRails and installed the components separately and even though I had a few hurdles I did manage to get everythng working OK.

    It's been a while so I've forgotten the actual steps I took, but I think if you try to install everything separately too you'll have better luck.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •