SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Evangelist cgacfox's Avatar
    Join Date
    Feb 2005
    Location
    Colorful Colorado
    Posts
    412
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Problems with GoDaddy.com and php5.ini file

    I recently created a php5.ini file to run my PHP contact form on godaddy.com but when I added it, it broke WordPress. Now the godaddy techs say I need to make a full php5.ini file to run WordPress. I am not sure how to do this. I am currently on a Windows server running IIS7. Here is what is in my .ini file.

    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = ”EGPCS”
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = ”a=href,area=href,frame=src,input=src,form=,fieldset=”

    [Zend]
    zend_extension=/usr/local/zo/ZendExtensionManager.so
    zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

    Could someone please help me with what I need to add to run not only my contact form but WordPress. Just to let you know when I go to http://foxdenwebsolutions.com/blog I get an error –

    Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    I tried to do a upgrade to WP 2.9.2 but also get an error.

    Here is what the tech said –

    After looking into your account, and the issues that you are experiencing with connecting to your database using php, we have found that the php5.ini file that you have uploaded is causing these problems. By default, the php_mysql extension is available within your shared hosting environment. It is only when you add your own php5.ini to the account that you see the errors. Furthermore, you will need a full php5.ini with a IIS7 Hosting account. You should be able to find more information about full php.ini files online by using your favorite search engine.

    Currently, In troubleshooting this issue, we have found that the extension needed for php connections with MySQL databases is not loaded with a custom php5.ini file. You will need to add the following extension to your php5.ini file so that MySQL connections with php are available:
    Code:
    extension=php_mysql.dll
    Also, please note that you will need to load it from the server extensions directory, which will also need to be updated within your php5.ini file:
    Code:
    extension_dir = C:php5ext
    As with any change to your php.ini file, you will need to recycle your application pool from within the IIS Settings of your Hosting Control Center before any modifications are updated.
    To Recycle the Application Pool
    on Windows Shared Hosting Accounts

    1. Log in to your Account
    Manager.

    2. In the My Products section, select Hosting.

    3. Next to the hosting account you want to modify, click Manage
    Account.

    4. In the Content section of the Hosting Control
    Center, click the IIS Management icon.

    5. Click Recycle App Pool
    and follow any prompts.

    Once you have correct the issue with your php5.ini file, you should Rollback the Installation through the Hosting connections and reapply the update.
    Please contact us if you have any further issues.

    Sorry this is so long but I do not know exactly how to do this. The contact form is in HTML and links to a php handler page.

    I do have the option of switching to a Linux account, but I am afraid that if I do this my contact form will be broken as well. I know that most of you will tell me to get away from godaddy but I recently paid for a year of hosting and cannot afford to switch hosting companies at this time.

  2. #2
    SitePoint Evangelist cgacfox's Avatar
    Join Date
    Feb 2005
    Location
    Colorful Colorado
    Posts
    412
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    NM found the problem...they gave me the incorrect syntax for the extension_dir. I changed it to C:\php5\ext and it works now with the php5.ini file that I have currently. I also checked my contact form and it still works!

    This is the only code I have in my .ini file running on Windows IIS7 at godaddy.com just in case someone else has the same problem.

    Code:
    register_globals = off
    allow_url_fopen = off
    
    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension=php_mysql.dll
    extension_dir = C:\php5\ext
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
    
    [Zend]
    zend_extension=/usr/local/zo/ZendExtensionManager.so
    zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

  3. #3
    SitePoint Member
    Join Date
    Nov 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey im having the same problem but i have no idea what any of that means. do i just create a file called php5.ini, copy that code, and place the file in the root directory?

  4. #4
    SitePoint Member
    Join Date
    Jan 2011
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Useful, thanks for posting your iis 7.0 windows php5.ini file


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •