SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Threaded View

  1. #1
    SitePoint Member
    Join Date
    Apr 2010
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    shovell-debug-01 not starting up

    Hi all,

    I'm on chapter 11 of the book, Simply Rails 2, and have followed the instruction to start the server using the shovell-debug-01 folder and files.

    However, when I attempted to do that, I got the following error:

    Code:
    Missing the Rails 2.0.2 gem. Please `gem install -v=2.0.2 rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.
    As I am running the 2.3.5 version of rails (the latest that I got from gems), I commented out the RAILS_GEM_VERSION line.

    Upon trying to start the server, I then got the following error and the server doesn't start.

    Code:
    /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:602:in `send': undefined method `cache_template_extensions=' for ActionView::Base:Class (NoMethodError)
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:602:in `initialize_framework_settings'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:601:in `each'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:601:in `initialize_framework_settings'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:598:in `each'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:598:in `initialize_framework_settings'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:155:in `process'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `send'
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
    	 ... 6 levels...
    	from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:84
    	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
    	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
    	from script/server:3
    Could somebody tell me what is going wrong, and how I am able to fix it? I don't actually wish to downgrade my version of rails to the 2.0.2... I'm stuck at this stage of the book until I can get this to work.

    edit: yes, I do get the same error when I am attempting to run shovell-debug-02
    Last edited by kriston; May 2, 2010 at 23:44. Reason: update


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •