SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast mecha51's Avatar
    Join Date
    Dec 2008
    Location
    Raleigh, NC
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Has my WordPress site been hacked???

    Hi. I've had a WP site for a little over a year. It's a pretty simple site that I use mostly as a portfolio, although I try to blog a little every now and then as well.

    Last week I went to my site and got the WP install screen. I've taken that down for now and just put up a blank page. Now I'm trying to figure out what happened.

    I've done a bunch of reading and have poked around in the db a bit. I don't see anything suspicious--new files/directories or user accounts. I also contacted my hosting provider, and they were not helpful at all.

    Has anyone else had this happen to them? Is it a sure sign of a hack? What should I be looking for? Thanks in advance.

  2. #2
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,072
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Has your host changed anything like the configuration of the server on which the blog is hosted? Have you looked through all your log files (especially error logs) for anything which stands out as unusual?
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  3. #3
    SitePoint Enthusiast mecha51's Avatar
    Join Date
    Dec 2008
    Location
    Raleigh, NC
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SpacePhoenix View Post
    Has your host changed anything like the configuration of the server on which the blog is hosted? Have you looked through all your log files (especially error logs) for anything which stands out as unusual?
    I used the chat feature (which I find a lot less reliable than talking on the phone) and the rep said nothing had changed with them. I asked her to look at my log files and she would not.

    I have my log files open in notepad right now. The problem is I'm a n00b with all of this and don't know what specifically to be looking for.

  4. #4
    SitePoint Wizard bronze trophy bluedreamer's Avatar
    Join Date
    Jul 2005
    Location
    Middle England
    Posts
    3,402
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Check your wp-config file to make sure your database settings are correct.

  5. #5
    SitePoint Enthusiast mecha51's Avatar
    Join Date
    Dec 2008
    Location
    Raleigh, NC
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by bluedreamer View Post
    Check your wp-config file to make sure your database settings are correct.
    I thought they were. I changed the password and now site is back up.

    Weird. I have no idea what happened. I didn't work on the site at all last week.

  6. #6
    SitePoint Wizard bronze trophy bluedreamer's Avatar
    Join Date
    Jul 2005
    Location
    Middle England
    Posts
    3,402
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Who knows! I have known of web hosts that have chnaged passwords from time to time without informing clients.

    Glad you got it sorted>


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •