SitePoint Sponsor

User Tag List

Results 1 to 12 of 12

Hybrid View

  1. #1
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello All,

    I put a 'no-cache' tag in the head of one of my HTML docs and I still have to clean out my browser's cache, even after I've realoaded the page by clicking the refresh button in IE 5.0.

    Here's the header, take a look and let me know if I missed something. Do I need to move it closer to the top?

    <html>
    <head>
    <title>Cosmic Custom Airbrush Q&A Message Board</title>
    <meta name="keywords" content="cosmic custom airbrush,paint,airbursh,custom,cars,motorcycles,vans,trucks,helmets,t-shirts,tshirts,painting supplies,tips,harley-davidson,harley,honda,acura,volkswagon,aloha,hawaiian,art,">
    <meta name="description" content="Cosmic Custom Airbrush - Hawaii's premier custom airbrush studio specializing in motorcycles and helmets, cars, trucks, vans, and anything else that can be painted.">
    <meta name="content" content="general">
    <meta name="rating" content="all ages">
    <meta name="author" content="C and M Web Design">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <meta content="no-cache" http-equiv="Pragma">
    <style type="text/css">
    <!--
    a { font-weight: bold; color: #000099; text-decoration: none}
    a:hover { font-weight: bold; color: #00BD7B; text-decoration: none}
    -->
    </style>
    </head>
    <body bgcolor="#FFFFFF" text="#000000" link="#000099" vlink="#000099">

    Thanks,

    Mike


  2. #2
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Not all browsers support this tag as with any other tag. While the W3C puts out a recommended list of Tags for a HTML specification, the browser company gets to decide whether or not they it and to what extant. I believe that Microsoft's implementation of this tag is spotty at best and it should be used with caution.

    ------------------
    Wayne Luke

    The Majormud Encyclopedia - www.bloodquest2.com
    Come Play one of the hottest games on the net.



  3. #3
    jbm
    SitePoint Community Guest
    Well,
    there is a known bug in Netscape ( http://www.jp.netscape.com/security/notes/nocache.html ). In IE theres is also a bug (surprise, surprise) the description and fix are at http://support.microsoft.com/support.../Q222/0/64.ASP

    jbm

  4. #4
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I checked the documentation you pointed to and I think I'll give it a shot. Thanks a lot!

  5. #5
    jbm
    SitePoint Community Guest
    welcome

  6. #6
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The Netscape issue was null as it worked just fine in Netscape, but with IE, it still won't do what I want it to and I'm applying the code suggested.
    It's a simple forum at http://www.cosmicairbrush.com/forum/. Please take a look and let me know what's going on.

    Mike

  7. #7
    jbm
    SitePoint Community Guest
    it seemed to work fine for me, the page wasn't cached. I also looked at your code and didn't see anything that would make it not work... i'll look at it again tonight just to make sure.

    jbm

  8. #8
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just tried it and it worked just fine for me too. But if you still have time, another look would be greatly appreciated.

    Mike

  9. #9
    SitePoint Member
    Join Date
    Feb 2000
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    Try this code, it might work:

    <meta http-equiv="expires" content="0">

    -Jason Weinstein
    weinstein@sympatico.ca
    http://www.maximumedge.com

  10. #10
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fluffer,

    We got it to work, butI'll definately add that bit of code to my bag of tricks

  11. #11
    jbm
    SitePoint Community Guest
    DynaMike, I just looked at it again and it seems to work just fine.

    jbm

  12. #12
    ********* Addict
    Join Date
    Feb 2000
    Location
    NE FL, USA
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, it's working just fine! Thanks for all your help!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •