SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member lncr12's Avatar
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE6- won't scroll to bottom of content

    Hey sitepoint.

    this is my first post. i tried searching for an existing thread that would answer my question but couldn't find one, so here goes.

    my problem is that in internet explorer 6 the scroll bar appears when i have more content than can fit in the screen, but doesn't go to the very bottom, it stops about 100px before reaching the bottom. this happens on pages that are different lengths to start with. i have an invisible div that covers the entire page, and is activated when a person selects a certain link. i thought this might be the cause( and it still may be). on one page the height of this "overlayer" div corresponded with how far the page would scroll. but on other pages, where the content is much longer it continued on past this div, but still stopped before reaching the bottom.

    i know there is some issues with min-height, which i use on my container div but when i remove or change this the problem is still there.

    if anyone has any ideas it would be much appreciated.
    Never let a computer know you're in a hurry. ~Author Unknown

  2. #2
    SitePoint Enthusiast
    Join Date
    Oct 2009
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The scroll bar by default should be reaching the bottom of the page, so clearly something is interferring with this, which sounds like it could be this "overlayer invisible div".

    Do you have a link to the page in question, or an example page?

    And BTW min-height doesn't work in IE6, because it doesn't recognize it. However there's a hack to get around that if you ever need it, because IE6 just treats height as other browsers treat min-height

  3. #3
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,564
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Hi, as tom_tom_10 indicated it's impossible to tell what the issue is (since it's so vague and could be nearly anything) without having a link to look at (or full code)

    If you find you are having trouble posting the link (you have under 5 posts) then obscure the link as such and we will do the rest

    sitepoint dot com slash page dot php
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work

  4. #4
    SitePoint Member lncr12's Avatar
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i figured out a solution.the "bottom" div had a top:150px property so it was moving off the screen 150px on the bottom. I fixed it by adding margin-bottom:150px.


    thanks for your eagerness to help anyways. if i have any other questions i will definitely come back.
    Never let a computer know you're in a hurry. ~Author Unknown


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •