SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Jul 2006
    Posts
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Horizontal List and Color Issue in IE7

    I am trying to create a simple webpage with a horizontal list as the navigation, but IE (at least IE7) isn't accepting my horizontal list or my font colors. I've got it as inline, but it's still not working. Works great in FF, Safari and Chrome.

    The website is www DOT familylegacy2010 DOT com

    Here is the applicable CSS and HTML:

    Code:
    #nav {
    		position:relative;
    		text-align:right;
    		margin-right: 80px;
    		margin-top:50px;
    		list-style: none;
    		}
    #nav li {
    		display:inline;
    		}
    #nav li a {
    		padding-left: 25px;
    		color:#ffffff;
    		text-decoration: none;
    		font-variant:small-caps;
    		font-weight:bold;
    		}
    #nav li a:hover {
    		color: #000000;
    		text-decoration: underline;
    		}
    Code:
    <div id="nav">
    		<ul>
    		<li><a href = "http://www.familylegacy2010.com/banquet.html">the banquet</a></li><li><a href = "http://www.familylegacy2010.com/table.html">reserve a table</a></li><li><a href = "http://www.familylegacy2010.com/zambia.html">about zambia</a></li><li><a href = "http://www.familylegacy2010.com/familylegacy.html">about us</a></li><li><a href = "http://www.legacymissions.org">legacymissions.org</a></li></ul></div>

  2. #2
    SitePoint Enthusiast wildsue's Avatar
    Join Date
    Oct 2003
    Location
    Switzerland
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    first you could try to give your document a document type declaration. And then close the script-tag without backslash.
    Because at the moment the IE 8 doesn't recognize your CSS.

    Susanne
    SUTANET Webpublishing
    Susanne Tanner Ruppe
    Professional Webdesign from Switzerland since 2003!
    www.sutanet.ch - kontakt@sutanet.ch

  3. #3
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,726
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Hi, ignoring the fact you don't have a doctype on your page (which will slightly screw up your simple page as of right now) the problem is the quotation mark you have at the end of the background rule. It's making IE ignore the other rules
    Code:
    body{
    	margin:0px auto;
    	font-size: 18px;
    	font-family: Helvetica, Verdana, Arial, Sans-Serif;
    	background: #536e8d url('images/background.jpg') no-repeat top center;"
    	color: #ffffff;
    	}
    Always looking for web design/development work.
    http://www.CodeFundamentals.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •