SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Jan 2008
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Wordpress and Joomla: Error establishing a database connection

    Wordpress:
    I know the user and pass is correct and the DB and hostname also. I can connect fine via mysql command line.


    I am also getting with joomla:

    Okay so I navigate to the installer folder and run installer.php which tosses this error:

    "Restricted access"


    I read on this post :
    http://softmarket.ro/joomla-tips/im-get ... oomla.html

    Which said:
    <post>
    Installation Joomla 1.0.11 or 1.0.12 I was getting "Restricted access" after uploading all installation files to my hosting provider. after trying to set some other rights to the files, i had no success. finally i debugged a little the process and with a define( '_VALID_MOS', 1 ); placed in installation/index.php as the first php code line solved the problem i suppose with it it's not really secure, but you have to delete the installation folder anyway..
    </post>


    I did that and ran it again and now it comes up with this error:

    PHP Notice: Use of undefined constant DS - assumed 'DS' in C:\Websites\Joomla\installation\installer\installer.php on line 20

    PHP Warning: require_once(C:\Websites\Joomla\installation\installerDScontroller.php) [function.require-once]: failed to open stream: No such file or directory in C:\Websites\Joomla\installation\installer\installer.php on line 20

    PHP Fatal error: require_once() [function.require]: Failed opening required 'C:\Websites\Joomla\installation\installerDScontroller.php' (include_path='.;C:\php5\pear') in C:\Websites\Joomla\installation\installer\installer.php on line 20

    I basically did this:

    define( '_VALID_MOS', 1 );
    //defined('_JEXEC') or die('Restricted access'); <--- commented out this line..

    If i don't then i get the restricted access issue.

    It can't be this hard to install can it? I have installed DotNetNuke and a few other CMS type sites without problems.

    Any help is appreciated.

    MySql is setup on the default port etc. What could be the issue? I can connect to the MySql server fine with command line and with navicat. Thanks for your time.

  2. #2
    Mazel tov! bronze trophy kohoutek's Avatar
    Join Date
    Aug 2004
    Location
    Hamburg, Germany
    Posts
    4,248
    Mentioned
    30 Post(s)
    Tagged
    0 Thread(s)
    Hello belcherman,

    please do not cross-post. The thread is located here.

    Thread closed.
    Maleika E. A. | Rockatee | Twitter | Dribbble




Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •