SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    ie6 shows my page differently than Google Chrome

    Hi everyone,
    This is my page's code:
    Code:
    <style type="text/css">
      * {margin:0;padding:0;} 
      #title_wrapper {width:1005px; overflow:hidden}
      img {float:left;padding:4px;}
      #me {width:780px;margin-left:110px;float:left;}
      h1.myHeader {color:#900; margin-left:400px; margin-top:-50px;}
      
      #lower_menu 
       {
        margin-left:300px; 
        /*border-top:2px solid red;*/
        float:left;
       }
      #lower_menu a:link {text-decoration:none;}
      #lower_menu ul {float:left; margin-top:0px;} 
      #lower_menu li 
       { 
        list-style-type:none; 
        float:left;
       }
    </style>
    </head>
    
    <body>
    
      <div id="title_wrapper">
        <img src="logo2.gif"/>
        <img src="attention.gif"/>
        <img src="logo_small.gif"/>
      </div>
      <h1 class="myHeader">ATTENTION !!!</h1> 
      <div id="me"><img src="rounded_corners_me-and-my-k.jpg" /></div>
      <div class="myText">
    </div>
    <div id="lower_menu">
        <ul>
          <li><a href="#"><img src="previous_outer.jpg" /> </a></li>
          <li><a href="#"><img src="home.jpg" /></a></li>
          <li><a href="#"><img src="next_outer.jpg" /></a></li>
        </ul>
      </div>
    </body>
    Attached is image 1 showing what it looks using Google Chrome and image2 when ie6 is used. Using ie6, 3 image links are surounded wityh a border. Why? Why cant i see my elements in the same order as with "Google Chrome"?
    This page is located at:
    http://avirot.bravehost.com/to_forum.html
    Could anyone give me an hand "unifying" ie6 and Google Chrome ?
    I'll be grateful.
    Thanks
    Attached Images Attached Images

  2. #2
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,564
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Hi, I haven't even looked at the site but I notice you are running into the double float margin bug here
    Code:
     #me {width:780px;margin-left:110px;float:left;}
    You give a horizontal margin the same direction as the float (left margin, left float)

    IE6 will double that margin. It needs to get "display:inline;"
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work

  3. #3
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That "double float" is somethin new to me but you solving problems is very familiar . I'll try to understand my mistake.
    Thank you so much !

  4. #4
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,564
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    It wasn't your mistake, per say, it was just IE6 being IE6 lol
    Reading.

    You're welcome .
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work

  5. #5
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the link. Thanks for everything..


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •