SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unable to connect remotely to MSSQL 2008

    Hello,
    am running MSSQL 2008 and cant seem to enable remote login with the IP address.

    I have enabled
    1. remote login on the sql instance ( under facets )
    2. added the server IP to surface configuation manager to the TCP/IP configurations and enabled it
    3. I have enabled remote login on windows firewall
    4. I also ran netstat /a to check listening ports and the port 4533 is open and appears in the list, but not under the server IP, but under the 127.0.0.1 Ip and host name.

    However when i try to login with the IPaddress,port number either directly through the server or remotely, I get this error message

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to xxx.xxx.xxx.xxx,4533.

    ------------------------------
    ADDITIONAL INFORMATION:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060)

    For help, click: http://go.microsoft.com/fwlink?ProdN...0&LinkId=20476

    ------------------------------
    BUTTONS:

    OK

  2. #2
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,576
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Unless something major changed I'm not aware of, isn't the default Sql port1433, not 4533?

    Also, windows firewall-wise, you need to allow SQL to take remote connections, not let windows do remote logins.

  3. #3
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    well i never use the default. Apart from that we have 3 instances running, so we always change the port.

    Yes, we enabled sql remote logins in windows firewall.

  4. #4
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,576
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Hmm, that could be the problem. I *think* you are supposed to run all instances on the same port so the SqlBrowser can do it's thing. I can confirm that we have had multi-instance servers sharing 1433 with zero problems.

    Is sql saying anything in the error logs?

  5. #5
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I finally sorted the problem, after changing the connection parameters i didnt restart the server, i have done so and can connect now, thanks for your assistnace

    Ehi


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •