SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru Todd Temple's Avatar
    Join Date
    Mar 2005
    Location
    Tennessee
    Posts
    797
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Trying To Replace Single Image Buttons With A Sprite

    My original site is http://www.t2graphicdesign.com/ and it uses separate images for each button in the main navigation (home-about-portfolio-etc.) and sub navigation (linkedin-facebook-twitter) menus.

    But now I am trying to replace the individual buttons with a large single image sprite. Here is my work in progress. I am stuck on the subnav menu at the top left.

    LINK-
    http://t2graphicdesign.com/index.021110.php

    Can someone tell me what I am doing wrong?

    Todd
    Todd Temple > T2 Design

  2. #2
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,564
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Hi, what exactly is wrong with it? You are applying sprites correctly and the image is changing to the new one respectively.

    Did you fix the issue?
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work

  3. #3
    SitePoint Guru Todd Temple's Avatar
    Join Date
    Mar 2005
    Location
    Tennessee
    Posts
    797
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by RyanReese View Post
    Did you fix the issue?
    Yeah, finally. At first I had the vertical and horizontal position values flipped and then it took me forever to figure out that I was entering positive numbers instead of negative numbers. Eventually after so many screw ups on certain aspects of CSS I am sure to figure out something, right? He he.

    Thanks for looking Ryan.
    Todd Temple > T2 Design

  4. #4
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,564
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Glad you got it sorted Todd
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •