SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: border problem

  1. #1
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    820
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    border problem

    http://mayacove.com/dev/test.html

    can't figure out whey there are there 3 extra pixels here inside the wrapper div, at the bottom, betw edge of img and the border... (markup & CSS validate..)

    am stumped here.. thank you..

  2. #2
    SitePoint Guru Luki_be's Avatar
    Join Date
    Jun 2008
    Location
    Brazil, Minas Gerais. But i'm from Belgium.
    Posts
    867
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try this:
    Code CSS:
     img {display:block;}
    SitePoint Guru
    Sitepoint - the ultimate Css well
    As a computer, I find your faith in technology amusing.
    Sitepoint reference, your friend in need

  3. #3
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,623
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    As Luki said it's the extra nodes left after inline elements. Either give it display:block; or one of hte other solutions posted here
    http://ryanreese.net/articles/mysterious-gap.php
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  4. #4
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    820
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    oh man... THAT WORKED!!

    thank you very much...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •