SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot
    Join Date
    Sep 2005
    Posts
    159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    How to stop IE adding www. and .com to addresses?

    Does anyone know how to stop IE from doing this? I've been prodding around in "Internet Options" but can't spot anything..

  2. #2
    SitePoint Guru
    Join Date
    Nov 2008
    Posts
    622
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    can you be more detailed on this.

    what are typing in the address bar.

    usually .com is accepted by browsers as default.

    like if there is any domain registered with "hello.com" and if you will type "hello" in address bar then .com gets automatically added at the end of domain name.

    this is what i have noticed many times.

    vineet

  3. #3
    SitePoint Zealot
    Join Date
    Sep 2005
    Posts
    159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, the problem is if I need to access an internal site called "fred", IE automatically adds www. and .com and takes me to www.fred.com instead. I don't want it to do this.

  4. #4
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,269
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    If you are talking about a file stored locally on your own computer and you are typing the address into the address bar of the browser then you need to use file:///C:/ followed by the path to the file.

    e.g. this is where my local files are stored:

    file:///C:/Documents%20and%20Settings/User/My%20Documents/websites/testing2/test.htm

    Of course you could just double click on the file from windows explorer and it will open in your current browser anyway.

    I'm not sure if this is what you meant though

  5. #5
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,784
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Try typing a slash on the end

    If you type http://fred/ or even just fred/ then IE should see that the address is complete and should not go adding the .com on the end.

    The alternative is to switch to using a different browser where the option to turn off the automatic adding of TLDs is easier to find.

    If you really want to turn it off in IE then you need to edit the registry to do it. The key you want is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    Explorer\Main\UrlTemplate
    where you will then find four entries for trying the address with .com .org .net and .edu on the end.
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">

  6. #6
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    IE is adding .com because when the computer looks up "fred" either first as a NetBIOS name, then local DNS cache, then DNS server, etc. If nothing is found for "fred" it adds .com, as an auto correction in case the user forgot to add it. As long as IE can find an entry for "fred" that points to an IP, it will not auto correct.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •