I have vanilla Mac OS X Leopard which comes with 1.8.6.

I am new to RoR so will be following tutorials on the net. Am I likely to find problems following them when using later versions of Ruby?

I am currently looking at this one which mentions 1.8.6 and 1.8.7 - http://www.railstutorial.org/book