SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: Rails 2 Newbie

  1. #1
    SitePoint Zealot basicwebus's Avatar
    Join Date
    Jul 2003
    Location
    Missouri
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Wink Rails 2 Newbie

    I am a newbie and just purchased the Rails 2 by Patrick Lenz book. Thanks for the forum. I have been wanting to learn Ruby and Rails for a long time. I appreciate all the help from everyone on the SitePoint forums. Maybe some day I will be able to contribute help to others.
    After the third time of reading the instructions,
    it finally soaks in to my thick skull.



  2. #2
    SitePoint Enthusiast
    Join Date
    Dec 2009
    Posts
    62
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Best of luck to you

  3. #3
    SitePoint Member
    Join Date
    Jan 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Another newbie here.
    I have installed Ruby on a PC running openSolaris 2009.06.
    I installed Ruby 1.8.7p72 and Ruby Gems 1.3.5. , then installed Rails 2.3.5.
    MySQL (5.1.41 Community Server) was already installed. I created the Rails application shovell. and I can start the application using ruby script/server. But when I come to use the console I get an error:
    ruby script/console
    Loading development environment (Rails 2.3.5)
    /usr/local/lib/ruby/1.8/irb/completion.rb:10:in `require': no such file to load -- readline (LoadError)
    from /usr/local/lib/ruby/1.8/irb/completion.rb:10
    from /usr/local/lib/ruby/1.8/irb/init.rb:252:in `require'
    from /usr/local/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
    from /usr/local/lib/ruby/1.8/irb/init.rb:250:in `each'
    from /usr/local/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
    from /usr/local/lib/ruby/1.8/irb/init.rb:21:in `setup'
    from /usr/local/lib/ruby/1.8/irb.rb:54:in `start'
    from /usr/local/bin/irb:13
    I have looked around on the web and found one suggestion to go back to ruby source code ruby-1.8.7-p72/ext/readline and run the following commands:
    ruby extconf.rb
    make
    make install
    But this made no difference.
    Any help appreciated.

  4. #4
    SitePoint Zealot basicwebus's Avatar
    Join Date
    Jul 2003
    Location
    Missouri
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you try installing the updates. You can check here:
    http://www.ruby-lang.org/en/news/200...248-released-/

    It looks like this release fixed a bunch of bugs in a previous version.
    Try it and then be sure to post if that fixes the problem. Or if it doesn't. Hopefully it will.
    After the third time of reading the instructions,
    it finally soaks in to my thick skull.




Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •