Hello,

I'm following the Simply Rails 2 book but am having an issue with the Ruby Gems aspect. After some research I found out that the place to get gems is now gemcutter.org, NOT rubyforge.org. I am running Leopard, so I'm not sure if the gems release was already on here or if it was installed by following the book instructions.

I ran the following commands as instructed by page 27 of the book.

curl -L http://rubyforge.org/frs/download.ph...gems-1.0.1.tgz | tar xz

cd rubygems-1.0.1

sudo ruby setup.rb

cd ..


Currently, if I execute

gem -v

The computer returns 1.0.1

This appears that the gem install was successful. However, if I run

sudo gem update --system

The computer returns the following.

Updating RubyGems...
ERROR: While executing gem ... (Gem::RemoteSourceException)
HTTP Response 403 fetching http://gems.rubyforge.org/yaml

When I try to run

$ ruby script/server
Rails requires RubyGems >= 1.3.1 (you have 1.0.1). Please `gem update --system` and try again.

So, after a little research, I found that Gemcutter is where I should be fetching gems from at this point. I attempted the following.

sudo gem sources list

The computer only returned rubyforge, so I attempted to add gemcutter with the following command.

$ sudo gem sources -a http://gemcutter.org/
ERROR: While executing gem ... (Gem::RemoteSourceException)
HTTP Response 403 fetching http://gemcutter.org/yaml

In other words, I can't get the gem update command to work, and I can't get the add gemcutter command to work. I am getting the same error for both.

Mac OSX Leopard 10.5.8
$ ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]

I would really appreciate any help. Thanks so much.