SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Nov 2007
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    InnoDB: Operating system error number 5 when trying to reset root password

    I am using the command line in trying to reset the root password in MySQL 5.1 using mysqld.exe but all I get is:

    091113 20:59:36 [Note] Plugin ‘FEDERATED’ is disabled.
    091113 20:59:36 InnoDB: Operating system error number 5 in a file operation
    InnoDB: The error means mysqld does not have access rights to
    InnoDB: the directory. It may also be you have created a subdirectory
    InnoDB: of the same name as a data file.
    InnoDB: File name .\ibdata1
    InnoDB: File operation call: ‘open’.
    InnoDB: Cannot continue operation.

    When I look around for a solution I get the impression that this is not MySQL but Microsoft. Can anyone help me reset the MySQL root password?!

    Thanking you in advance,

    Glenn.

  2. #2
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    your data folder and mysql configuration file are probably in non-default locations and you are not using the --defaults-file option to specify the path to the configuration file.

    you have two options:
    • use the --defaults-file option to specify the path to your configuration file
    • instead of starting mysql from the command line, add skip-grant-table to your configuration file and start the server normally. log in and reset the password. remove skip-grant-tables and restart the server to return to normal operation.
    Check out our new Industry News forum!
    Keep up-to-date with the latest SP news in the Community Crier

    I edit the SitePoint Podcast

  3. #3
    SitePoint Member
    Join Date
    Nov 2007
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you longneck.

    I discovered that the problem was indeed Microsoft! I needed to run mysqld.exe under admin privileges. Once I did that the the password changed and all I needed to do was restart MySQL as a service and login using the reset password.

    Very many thanks for you help and support.

    Best regards,

    Glenn.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •