SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict
    Join Date
    Jul 2006
    Location
    Fionnphort, Isle of Mull, Scotland
    Posts
    337
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    How can I re-set MySQL server time-out ?

    My local phpMyAdmin (or more probably the underlying MySQL) keeps timing out after half an hour, and I have to log in again. This may be a good secrity feature in a production environment, but its very irritating during development, How can I reset it, please ?

    Conversely my production phpMyAdmin (at my web host) doesn't seem to time out at all, and has no 'Log Out' button on the dashboard. Should I be able to log out ? I want to log out, not close the MySQL server, of course.
    Tim Dawson
    Isle of Mull, Scotland

  2. #2
    Follow Me On Twitter: @djg gold trophysilver trophybronze trophy Dan Grossman's Avatar
    Join Date
    Aug 2000
    Location
    Philadephia, PA
    Posts
    20,580
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    It's probably the PHP session expiring, which is controlled through your php.ini file.

  3. #3
    SitePoint Addict
    Join Date
    Jul 2006
    Location
    Fionnphort, Isle of Mull, Scotland
    Posts
    337
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the suggestion, but I don't think that can be it.
    My access to MySQL via phpMyAdmin times out, but not my access via the php script on my web pages.
    I've searched php.ini on several terms (time, expire, session) but found nothing that looks likely.
    I also searched the phphMyAdmin folder on '1800', and found '$cfg['LoginCookieValidity'] = 1800;' BUT this is in a file called 'library/config.default.php' which is clearly marked 'do not edit, EDIT config.inc.php INSTEAD'. This line is NOT in 'config.inc.php'.
    So I'm going to try placing it there and playing with the time setting. Perhaps if there's no figure it won't time out.
    Tim Dawson
    Isle of Mull, Scotland

  4. #4
    SitePoint Addict
    Join Date
    Jul 2006
    Location
    Fionnphort, Isle of Mull, Scotland
    Posts
    337
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    That's definitely where the problem lies. I copied the line into config.inc.php and set the time to 3600 as: '$cfg['LoginCookieValidity'] = 3600;'. Now it times out every hour instead of every half hour.
    Tim Dawson
    Isle of Mull, Scotland


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •