SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Wordpress config issue?

    Client cannot "Preview" posts while in Edit mode. I tested the problem logged in as her and as Admin. Same problem happening with Admin....I can "View" post from the list of posts, but if I go into a post to edit and click Preview, I either get "Page Does Not Exist" or that I do not have "Permission to view drafts". This shouldn't be happening.

    I searched the WP forum (found nothing that helped) and called the hosting company. Hosting company said that it looks like WP was installed into a directory and then changed, however, the location or domain name or URL or something was never changed. Said we have it installed on a subdomain vs a sub directory or something. We need to change the WP config to match. They said this would cause issues with permissions. The site is redirecting from one place to another. Something about updating connection string, converting files over or something...

    I don't feel skilled enough in this area to start changing things. Anyone know about this kind of thing?

    Thanks so much in advance.

  2. #2
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

  3. #3
    SitePoint Enthusiast jrai's Avatar
    Join Date
    Dec 2008
    Location
    NYC / UK / Europe
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi -

    I can probably figure this out for you without much problems. Honestly, Wordpress is so versatile it's usually painless to move it from one directory to another completely (I've done this plenty of times). Plus, I use GoDaddy with a lot of domain aliasing to subdirectories, so I often have a lot of issues with 'automatic pathfinding' and paths in scripts as it is. Not sure what your setup is (host, server, WP version, etc.) but if you need help with this, I may be able to figure it out for you. If not, try one of my freelancers at the link below, they might be able to help, too.

  4. #4
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Jrai,

    That's great! Should I PM you the login info?

    How'd you know it was GoDaddy :-) ?

  5. #5
    SitePoint Enthusiast jrai's Avatar
    Join Date
    Dec 2008
    Location
    NYC / UK / Europe
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just taking a wild guess!

    PMed you my contact info, just let me know if you need help.

  6. #6
    SitePoint Guru
    Join Date
    Oct 2008
    Location
    Melbourne
    Posts
    754
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    While this is sort of about blogging, I think it's better served in the Content Management area -- it's more of a config problem than the act of actually blogging, and that area is full of wordpress experts.
    "I'm Commander Shepard, and this is
    my favourite post on the internet."

    We'll miss you, Dan Schulz.

  7. #7
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh....thanks for the correction, Reana. Should I repost it there or will that create problems (two of the same post)?

  8. #8
    SitePoint Guru
    Join Date
    Oct 2008
    Location
    Melbourne
    Posts
    754
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I moved it already. Enjoy!
    "I'm Commander Shepard, and this is
    my favourite post on the internet."

    We'll miss you, Dan Schulz.

  9. #9
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Raena. Can you send link to it?

  10. #10
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oooops...looks like this is the new post?

  11. #11
    SitePoint Guru
    Join Date
    Oct 2008
    Location
    Melbourne
    Posts
    754
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, it all moved
    "I'm Commander Shepard, and this is
    my favourite post on the internet."

    We'll miss you, Dan Schulz.

  12. #12
    SitePoint Guru
    Join Date
    Feb 2006
    Posts
    980
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Figured this one out....it was in WP Admin Settings. The WordPress address (URL) was set to the parent URL/(domain name) subdirectory. The Blog URL was set to the domain name URL. I changed the WordPress address (URL) to the Blog URL.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •