SitePoint Sponsor

User Tag List

Results 1 to 9 of 9

Thread: Quotes in IE8

  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2008
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Quotes in IE8

    Hi,

    Does anyone know how to fix apostrophes and quotes for IE8 or know why they aren't working right. The site looks fine in Firefox, but then gives weird text for IE8.


    I looked through the forums but didn't find anything, is there a forum on this?

    Would adding this code work?:

    meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"

    Thanks!

  2. #2
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Link?

  3. #3
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,585
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Sometimes when copying text over depnding on what content typue is being specified/font it can render the quotes as question marks (?)

    You have to manually go in the file and replace them.
    Twitter-@Ryan_Reese09
    http://www.ryanreese.us -Always looking for web design/development work

  4. #4
    SitePoint Enthusiast
    Join Date
    Dec 2008
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    good point, sorry about no link:

    http://www.nabsys.com/

    for instance right after the word "world" or "the shorter these"

  5. #5
    SitePoint Wizard bronze trophy C. Ankerstjerne's Avatar
    Join Date
    Jan 2004
    Location
    The Kingdom of Denmark
    Posts
    2,702
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Your text is encoded as UTF-8, but your server is sending it as Latin-1. Setting up the server to send the page as UTF-8 will solve the problem (this should be done server-side, but adding <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> to the head section should do the trick too).
    Christian Ankerstjerne
    <p<strong<abbr/HTML/ 4 teh win</>
    <>In Soviet Russia, website codes you!

  6. #6
    SitePoint Enthusiast
    Join Date
    Dec 2008
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks very much. I will give it a try.

  7. #7
    SitePoint Addict SilentBobSC's Avatar
    Join Date
    Mar 2005
    Location
    South Carolina
    Posts
    226
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't forget about the fact the the 'stylized' quotes (the ones that angle in, like you see on Word documents, and that look like the ones you're having issues with) need to be implemented with the 'special-character' codes. Try copying the offending text into your text editor of choice (I prefer Notepad++, personally) and replace the quotes.

    I believe the codes for open and close quotes are: &*ldquo*; and &*rdquo*; (remove the *s)

    These can cause all kinds of headaches, particularly with Server-side scripts and technologies like .Net and such.
    Last edited by SilentBobSC; Oct 9, 2009 at 11:17. Reason: Added the codes for the quotes

  8. #8
    SitePoint Wizard bronze trophy C. Ankerstjerne's Avatar
    Join Date
    Jan 2004
    Location
    The Kingdom of Denmark
    Posts
    2,702
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    If you use UTF-8, there's no need for the character entities.
    Christian Ankerstjerne
    <p<strong<abbr/HTML/ 4 teh win</>
    <>In Soviet Russia, website codes you!

  9. #9
    SitePoint Enthusiast
    Join Date
    Dec 2008
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for all your help. Really appreciate it and its working correctly now. Just used the meta tags.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •