SitePoint Sponsor

User Tag List

Results 1 to 11 of 11
  1. #1
    SitePoint Member
    Join Date
    Apr 2009
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP + SOAP. Could not connect to host

    Yes, I know that the issue has already been discussed on the forum, but it remains unsolved

    On my localhost with:

    Ubuntu 8.10, Apache 2.2.9, PHP 5.2.6

    i create soap object using wsdl file stored localy and send request to _https://gatewaybeta.fedex.com:443/web-services and got successfull response.

    On production server with:

    CentOS, WHM, Apache 2.2.11, PHP 5.2.9

    i create soap object using wsdl file stored localy and trying to send request to _https://gatewaybeta.fedex.com:443/web-services but got error:

    Code PHP:
    [ERROR_SOAP] => string(44)  Code: HTTP; Descr: Could not connect to host

    Telnet from production server to _https://gatewaybeta.fedex.com:443/web-services on port 443 is success.

    SOAP requests from production server to mobilestorm are success.

    Also, tcpdump -vvv didn't catch any outgoing requests from production server to fedex server while sending soap requests.

    What may cause such problem ?
    Thnx in adv.

  2. #2
    SitePoint Wizard silver trophybronze trophy Cups's Avatar
    Join Date
    Oct 2006
    Location
    France, deep rural.
    Posts
    6,869
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Did you compare the php.ini files?

  3. #3
    SitePoint Member
    Join Date
    Apr 2009
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Didn't. But the other soap requests to mobileStorm, for example, are success. The php soap extension is turned on (it's obvious )) ) and as i mentioned above, we using WHM, and it tune everything on the fly to fit it needs. php.ini as well.

  4. #4
    SitePoint Wizard silver trophybronze trophy Cups's Avatar
    Join Date
    Oct 2006
    Location
    France, deep rural.
    Posts
    6,869
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    I was thinking more of things like safe mode, tmp file location, allow_url_fopen ..

    I am sorry, I don't have any other ideas why one soap service would work and not another on the same server.

  5. #5
    SitePoint Member
    Join Date
    Apr 2009
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Cups View Post
    I was thinking more of things like safe mode, tmp file location, allow_url_fopen ...
    thnx anyway ))

  6. #6
    SitePoint Member
    Join Date
    Apr 2009
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Solved.

    Changing

    'location' => 'https://gatewaybeta.fedex.com:443/web-services'

    to

    'location'=>'https://199.81.198.77:443/web-services'

    helps ))

    Seems, kinda soap name resoution problem.....

  7. #7
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi .. I am getting the following error when sending a request. I am unable to find what could be causing this error. can any one comment on this issue?

    There was an error with your request or the service is unavailable. SoapFault Object ( [message: protected] => Could not connect to host [string: private] => [code: protected] => 0
    [line: protected] => 49
    [trace: private] => Array ( [0] => Array ( [function] => __doRequest [class] => SoapClient [type] => -> [args] => Array ( [0] => 2dafd27f61e441cb9f41c841fc
    [1] =>10.131.2.110/services/soapLinks/ [2] => [3] => 1 [4] => 0 ) ) [1] => Array ( [function] => __call [class] => SoapClient [type] => -> [args] => Array ( [0] => getBannerLinks [1] => Array ( [0] => Array ( [token] => 2dafd27f61e441cb9f41c841fc
    [mid] => 35520 [page] => 1 ) ) ) ) [2] => Array ( [line] => 49 [function] => getBannerLinks [class] => SoapClient [type] => -> [args] => Array ( [0] => Array ( [token] => 2dafd27f61e441cb9f41c841fc [mid] => 35520 [page] => 1 ) ) ) ) [faultstring] => Could not connect to host [faultcode] => HTTP )

  8. #8
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have occur the the following error........please help me


    [There was an error with your request or the service is unavailable. SoapFault Object ( [messagerotected] => Could not connect to host [stringrivate] => [coderotected] => 0 [filerotected] =>.. \soap_text.php [linerotected] => 11 [tracerivate] => Array ( [0] => Array ( [function] => __doRequest [class] => SoapClient [type] => -> [args] => Array ( [0] => dd95819c3fb81bcb6dfd8 [1] => 10.1.7.142/services/soapLinks/ [2] => [3] => 1 [4] => 0 ) ) [1] => Array ( [function] => __call [class] => SoapClient [type] => -> [args] => Array ( [0] => getStoreLinks [1] => Array ( [0] => Array ( [token] => d95819c3fb81bcb6dfd8 [mid] => 35379 [page] => 1 ) ) ) ) [2] => Array ( [file] =>.. \soap_text.php [line] => 11 [function] => getStoreLinks [class] => SoapClient [type] => -> [args] => Array ( [0] => Array ( [token] => d95819c3fb81bcb6dfd8 [mid] => 35379 [page] => 1 ) ) ) ) [faultstring] => Could not connect to host [faultcode] => HTTP )

  9. #9
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi ar1014, I got similar error and have notified linkshare. they are currently working on it. expecting a reply from them soon. will let you know if I have any updates. also pls keep me updated if you have any new information.

  10. #10
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi ar1014, any updates, were you able to fix the problem?

  11. #11
    SitePoint Enthusiast exoticshawls's Avatar
    Join Date
    Aug 2009
    Posts
    67
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i was having same problem and this thread was so hepful for me.thanksss buddies.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •